SpokePhone platform outage
Incident Report for Spoke Phone
Resolved
Our platform services are now operating normally. Calls and application functionality have now restored for all customers. We continue to monitor the platform for stability.
Posted Feb 16, 2023 - 18:25 NZDT
Update
Additional fixes are currently being applied to the Spoke Phone platform. We are awaiting for these to be deployed and services to be restarted prior to progressively enabling traffic for customers. Calls continue to be disrupted. We will post a further update in 1 hour or as soon as more information is available.
Posted Feb 16, 2023 - 16:53 NZDT
Update
The fix that was previously applied reduced pressure on the platform however did not completely resolve the issue and we are again seeing an increase in timeouts and API error rates. Calls continue to be disrupted. Our engineers are working to implement additional mitigations. We will post a further update within the next hour.
Posted Feb 16, 2023 - 15:20 NZDT
Identified
We have identified the issue and a fix has been applied. Service is restoring and we are seeing significantly reduced error rates and API latencies. Customers should now be able to make and receive calls on the Spoke application, and access to the Spoke account portal has recovered. Some calls may still be disrupted while the service recovers. Traffic to the Conversations service is currently throttled and there may continue to be delays to delivery/receipt of SMS messages.
Posted Feb 16, 2023 - 13:47 NZDT
Update
We are continuing to investigate this issue.
Posted Feb 16, 2023 - 13:20 NZDT
Investigating
We are currently experiencing significant platform service degradation. Engineers are investigating, and will provide an update in the next 30 minutes.
Posted Feb 16, 2023 - 13:19 NZDT
This incident affected: Spoke Applications (Account Portal, Spoke Mobile Application (iOS), Spoke Mobile Application (Android), Spoke Desktop App for Mac and Windows) and Voice (PSTN).