Issue purchasing new phone numbers
Incident Report for Spoke Phone
Resolved
We've fixed the issue. Administrators of Spoke cloud accounts can now purchase new phone numbers successfully.
Posted Apr 08, 2022 - 07:07 NZST
Investigating
We are experiencing issues with purchasing new phone numbers on our Account Portal. We are currently investigating the issue.

This affects all Spoke cloud accounts. Bring-your-own-Twilio customers are NOT affected.
Posted Apr 07, 2022 - 14:22 NZST
This incident affected: Spoke Applications (Account Portal) and Voice (Phone Number Management).