Spoke Phone Website Issues
Incident Report for Spoke Phone
Resolved
The issue is now resolved.
Posted Nov 19, 2021 - 15:31 NZDT
Update
We are continuing to investigate this issue.
Posted Nov 19, 2021 - 14:34 NZDT
Investigating
Our website is experiencing issues due to unexpected high traffic. We are working to resolve this quickly. Please try back soon.
Posted Nov 19, 2021 - 14:32 NZDT
This incident affected: Spoke Phone Public Website.